Master Pages option missing under “Look and Feel”


i was trying to implement SharePoint 2010 theme & feel that the atricle which i was reading having different feature than i have. i investiagted and found the solution. here i am going to share…

Source: Master Pages option missing under “Look and Feel”

AWS Marketplace Adds SharePoint Enterprise


SharePoint now available in AWS MarketPlace

SharePoint Enterprise is now available to purchase and deploy in AWS Marketplace. Designed to suit the needs of many different types and sizes of organizations up to and including multinational enterprises, SharePoint Enterprise supports custom applications, mobile applications, social media integration, business intelligence, and advanced content management

Source: https://aws.amazon.com/blogs/aws/aws-marketplace-adds-sharepoint-enterprise/

Trying to run PSConfig for SharePoint 2013 farm, but it is giving errors


Trying to run PSConfig for SharePoint 2013 farm, but it is giving errors that multiple components are missing on one of the servers in the farm.

Action Performed and Resolution:

  • Checked Central Admin, product and patch status, server PSConfig is showing errors for missing components for SP1 and security updates. Downloaded / Installed  SP1 on both the servers

Result:

———

PS C:\Users\SPAdmin> Get-SPProduct -local

ProductName                    Required   Missing              Servers

———–                    ——–   ——-              ——-

Language Pack for SharePoin… True                            {}

Language Pack for SharePoin… True                            {}

Microsoft SharePoint Server… True                            {}

————————————————————————————-

  • Cleared the SharePoint cache on both the servers and run the below PSConfig command on the app server

PSConfig -cmd upgrade -inplace b2b  -wait -force

Result:

———

PS C:\Users\sp13prod_SPAdmin> PSConfig -cmd upgrade -inplace b2b -wait -force

SharePoint Products Configuration Wizard version 15.0.4569.1503. Copyright (C) Microsoft Corporation 2012. All rights reserved.

The upgrade command is invalid or a failure has been encountered.The server farm will not work with missing installs. Add “-cmd installcheck -noinstallcheck” to the command-line to ignore this warning.

The following is missing on SPWB01:

Update for Microsoft SharePoint Foundation 2013 (KB3114492) 64-Bit Edition

Update for Microsoft SharePoint Foundation 2013 (KB3114492) 64-Bit Edition

Update for Microsoft SharePoint Foundation 2013 (KB3114492) 64-Bit Edition

Update for Microsoft SharePoint Foundation 2013 (KB3114492) 64-Bit Edition

Service Pack 1 for Microsoft SharePoint Server 2013 Language Pack (KB2880554) 64-Bit Edition

Service Pack 1 for Microsoft SharePoint Server 2013 Language Pack (KB2880554) 64-Bit Edition

Service Pack 1 for Microsoft SharePoint Server 2013 Language Pack (KB2880554) 64-Bit Edition

Update for Microsoft SharePoint Foundation 2013 (KB3114492) 64-Bit Edition

 

  • After navigating to “Control Panel  >  Programs > View installed updates”, observed that KB3114492 and KB2880554 are missing on web server SPWB01
  • Also, after navigating “Central Admin site > Upgrade and Migration > Check product and patch installation status”, observed that only on SPWB01  server KB3114492 and KB2880554 are missing.

————————————————————————————-

Update for Microsoft SharePoint Foundation 2013 (KB3114492) 64-Bit Edition

Service Pack 1 for Microsoft SharePoint Server 2013 Language Pack (KB2880554) 64-Bit Edition

———————————————————————————————-

  • Downloaded the below KB’s:

KB3114492: https://support.microsoft.com/en-us/kb/3114492

KB2880554 (English): https://support.microsoft.com/en-us/kb/2880554

  • Placed the both the KB’s on the same folder were the OPUTIL.EXE is placed
  • Run the OPUTIL.EXE
  • Cleared the SharePoint cache
  • Tried running the below PSConfig command on the app server

PSConfig -cmd upgrade -inplace b2b  -wait -force

 

  • Now it is complaining – KB2880554 is missing on both the servers (SPWB01,SPAS01)
  • Rebooted both the servers
  • Run the PSConfig command again
  • Now it is complaining – KB2880554 is missing on server SPWB01 only
  • When cross checked – observed that it is missing for French language pack (KB2880554)
  • Downloaded the KB2880554 for French language : https://www.microsoft.com/fr-FR/download/details.aspx?id=42543
  • Run “serverlpksp2013-kb2880554-fullfile-x64-fr-fr.exe”
  • Run the PSConfig command again on App server

PSConfig -cmd upgrade -inplace b2b  -wait -force

  • It completed successfully
  • Run the above PSConfig command on WFE server – It completed successfully
  • Accessed the Central Admin site, on the ‘Manage Servers in the farm’ page – we are able to see ‘No action required’ against all the servers.
  • From the ‘Review database status’ page – we are able to see ‘No action required’ against all the databases .
  • From the ‘Check product and patch installation status ‘ page –  we are not seeing Missing/Required patch errors
  • From the ‘Check upgrade status ‘ page – we are able to see all the servers upgraded successfully
  • Accessed one of the SharePoint Application site – confirmed we are able to access it successfully
  • Issue is resolved

 

SharePoint 2013 NewsFeed Picture Upload Problem


The Newsfeed is not working on Mysite in SharePoint 2013

– Unable to upload pictures to SharePoint 2013 newsfeed

Trying to upload images to NewsFeed in SharePoint 2013

sorry_this_site_hasnt_been_shared_with_you

Cause:

  1. The user profile service account does not have Full Control permission on User Profile service.
    2. The distributed cache service account does not have Full Control permission on User Profile service.
    3. The user profile service account does not have Full Control permission on my site web application.

Solution:

To correct this issue, complete the following steps:

  1. Log onto the SharePoint 2013 Central Administration site as a farm administrator
  2. Navigate to ‘Manage Service Applications’

    manage_service_application

  3. Highlight the User Profile Service Application
  4. Click the ‘Permissions’ ribbon toolbar button:

user_profile_service_applicaiton_permission

  1. Add the account that is used to run the User Profile Service Application and give it full control
  2. Click OK

permission_for_spprofile

  1. Open the SharePoint 2013 Management Shell by right-clicking and choosing ‘run as administrator’Issue the following PowerShell commands:

$webApp = Get-SPWebApplication http://<MySiteURL&gt;
$ webApp.GrantAccessToProcessIdentity(“domain/User Profile Service Application Account”)

Get-SPWebApplication

GrantAccessToProcessIdentity

At this point, the newsfeed should be up and running successfully:

 

SharePoint 2013 REST jQuery Slideshow


How to add jQuery Slideshow to SharePoint Site?

Excellent article about jQuery Slideshow to SharePoint at : http://bastiaanjacobs.nl/2014/04/09/sharepoint-2013-rest-slideshow/

Add an app > Picture Library > Name it “Banners” > Add some images

The result should be the following: